CVE-2026-102278
Description
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per nesting level at comma-member and single-set expansion sites, exhausting the native stack before output limits can apply and potentially terminating the Node.js process. expand_ performs uncontrolled recursion for nested brace alternatives and single-part sets. deeply nested brace groups supplied as an untrusted pattern. expand_ is affected. expand is affected. Comma members is affected. Single set is affected. native stack exhaustion during nested sub-expansion. process-terminating denial of service. This issue is fixed in versions 1.1.20, 2.1.6, 3.0.8, and 5.0.11.
How to fix
- brace-expansion5.0.11, 3.0.8, 2.1.6, 1.1.20 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| brace-expansionnpm | 4.0.0 ≤ v < 5.0.11, 3.0.0 ≤ v < 3.0.8, 2.0.0 ≤ v < 2.1.6, v < 1.1.20 | 5.0.11, 3.0.8, 2.1.6, 1.1.20 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.