CVE-2026-102495

High

Description

Apache XmlSchema doesn't limit how deeply schema imports and includes can be nested, so a malicious schema can make parsing recurse until the stack overflows. This causes a denial of service. Users are recommended to upgrade to version 2.3.3, which fixes this issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Xmlschema
PublishedSep 29, 2026
First seenSep 29, 2026
Weakness typeCWE-674CWE-674

How to fix

Update
  • apache xmlschema2.3.3 or later

Affected products

ProductAffected versionsFixed in
apache xmlschemav < 2.3.32.3.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-102495 · Apache Xmlschema · Dark Radar