CVE-2026-102827

High

Description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.

SeverityHigh
CVSS8.1
Exploit probability—
ProductSimple-git
PublishedSep 29, 2026
First seenSep 29, 2026

How to fix

Update
  • simple-git_project simple-git4.0.0 or later
  • simple-git4.0.0 or later

Affected products

ProductAffected versionsFixed in
simple-git_project simple-gitv < 4.0.04.0.0
simple-gitnpmv < 4.0.0, v ≤ 3.36.04.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.