CVE-2026-102828

Critical

Description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

SeverityCritical
CVSS9.8
Exploit probability—
ProductSimple-git
PublishedSep 29, 2026
First seenSep 29, 2026

How to fix

Update
  • simple-git_project simple-git4.0.1 or later
  • simple-git4.0.1 or later

Affected products

ProductAffected versionsFixed in
simple-git_project simple-git3.15.0 ≤ v < 4.0.14.0.1
simple-gitnpm3.15.0 ≤ v < 4.0.14.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.