CVE-2026-103119

Critical

Description

Buffer under-read vulnerability in Apache Tomcat meant that a large non-blocking write could result in the response body being split between the current request and the next request received on that connection leading most likely to failure of the second request and possibly leakage of data from the first response to the second. This issue affects Apache Tomcat: from 11.0.0-M25 through 11.0.26. Users are recommended to upgrade to version 11.0.27, which fixes the issue.

SeverityCritical
CVSS9.1
Exploit probability—
ProductApache Tomcat
PublishedOct 20, 2026
First seenOct 20, 2026
Weakness typeCWE-127CWE-127

How to fix

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Tomcat11.0.0-M25 ≤ v ≤ 11.0.26—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.