CVE-2026-103241

Medium

Description

A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.

SeverityMedium
CVSS5.3
Exploit probability—
ProductVllm
PublishedSep 30, 2026
First seenSep 30, 2026
Weakness typeCWE-404CWE-404

How to fix

Affected products

ProductAffected versionsFixed in
vllm vllmv ≤ 0.26.0—
vllmPyPIv < 0.27.00.27.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.