CVE-2026-103413

High

Description

Improper input validation vulnerability in Apache Camel Karavan. When a deployment was started, Karavan unmarshalled a project's `kubernetes.yaml` and applied every resource it contained to the cluster without restricting the resource kinds, without rejecting security-sensitive pod options, and without pinning the target namespace. An authenticated user of any role could therefore have Karavan apply arbitrary Kubernetes resources within the reach of its service account, including pods requesting hostNetwork, hostPID, hostIPC, hostPath volumes, host ports, privileged containers, privilege escalation or added capabilities. This issue affects Apache Camel Karavan: from 4.0.0 before 4.22.1. Users are recommended to upgrade to version 4.22.1, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Camel Karavan
PublishedOct 9, 2026
First seenOct 9, 2026

How to fix

Update
  • Apache Software Foundation Apache Camel Karavan4.22.1 or later

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Camel Karavan4.0.0 ≤ v < 4.22.14.22.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.