CVE-2026-103552
High
Description
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Directory LDAP API
PublishedOct 2, 2026
First seenOct 2, 2026
Weakness typeCWE-121CWE-121
How to fix
Update
- Apache Software Foundation Apache Directory LDAP API1.2.9 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Directory LDAP API | 1.2.0 ≤ v < 1.2.9 | 1.2.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.