CVE-2026-103877

Critical

Description

Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE.  This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Directory LDAP API
PublishedOct 2, 2026
First seenOct 2, 2026

How to fix

Update
  • Apache Software Foundation Apache Directory LDAP API2.1.9 or later

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Directory LDAP API2.1.0 ≤ v < 2.1.92.1.9

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-103877 · Apache Directory LDAP API · Dark Radar