CVE-2026-103956

Critical

Description

Missing authentication for critical function in the authentication dependency in Loom for AWS before 1.6.1 allowed remote actors to obtain super-admin authority over the agent control plane, including registering tool servers, reading stored integration credentials, and rewriting the IAM role policies attached to managed agent roles, via any request to the application API in a deployment where no identity provider is configured. To remediate this issue, users should upgrade to version 1.6.1 or later.

SeverityCritical
CVSS10.0
Exploit probability—
ProductAws Loom
PublishedOct 2, 2026
First seenOct 2, 2026

How to fix

Affected products

ProductAffected versionsFixed in
AWS loomv < 1.6.11.6.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.