CVE-2026-104019

Critical

Description

OS command injection in the Studio Space startup validation script in Amazon SageMaker Distribution 2.x before 2.14.12, 3.x before 3.9.12, 4.0.x before 4.0.11, 4.1.x before 4.1.11, 4.2.x before 4.2.8, 4.3.x before 4.3.5, and 4.4.x before 4.4.3, as used by Amazon SageMaker Unified Studio, might allow an authenticated remote user with project contributor permissions to execute arbitrary commands in another project member's Studio Space and obtain that member's temporary execution role credentials via a crafted connection resource property that is interpolated into a shell invocation without neutralization. To remediate this issue, users should upgrade to version 2.14.12, 3.9.12, 4.0.11, 4.1.11, 4.2.8, 4.3.5, or 4.4.3, as applicable to the minor line in use. Users on minor lines that have reached end of support must move to a supported minor line, because no patched version will be released for those lines. In Amazon SageMaker Unified Studio, Studio Spaces adopt the latest patch of their minor line on restart once the patched images are deployed, so no version selection is required.

SeverityCritical
CVSS9.0
Exploit probability—
ProductAws Sagemaker-distribution
PublishedOct 2, 2026
First seenOct 2, 2026

How to fix

Update
  • AWS sagemaker-distribution2.14.12, 3.9.12, 4.0.11, 4.1.11, 4.2.8, 4.3.5, 4.4.3 or later

Affected products

ProductAffected versionsFixed in
AWS sagemaker-distribution2.8.0 ≤ v < 2.14.12, 3.3.0 ≤ v < 3.9.12, 4.0.0 ≤ v < 4.0.11, 4.1.0 ≤ v < 4.1.11, 4.2.0 ≤ v < 4.2.8, 4.3.0 ≤ v < 4.3.5, 4.4.0 ≤ v < 4.4.32.14.12, 3.9.12, 4.0.11, 4.1.11, 4.2.8, 4.3.5, 4.4.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.