CVE-2026-104711

Critical

Description

Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Struts
PublishedOct 5, 2026
First seenOct 5, 2026

How to fix

Update
  • apache struts6.12.0, 7.4.0 or later

Affected products

ProductAffected versionsFixed in
apache struts2.0.0 ≤ v ≤ 2.3.37, 2.5.0 ≤ v ≤ 2.5.33, 6.0.0 ≤ v < 6.12.0, 7.0.0 ≤ v < 7.4.06.12.0, 7.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.