CVE-2026-105612

Low

Description

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

SeverityLow
CVSS3.5
Exploit probability—
ProductPostgreSQL Anonymizer
PublishedOct 28, 2026
First seenNov 4, 2026

How to fix

Update
  • DALIBO PostgreSQL Anonymizer3.3.0 or later

Affected products

ProductAffected versionsFixed in
DALIBO PostgreSQL Anonymizer1 ≤ v < 3.3.03.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.