CVE-2026-105613
Medium
Description
PostgreSQL Anonymizer's range-based dummy functions dont constraint the range size. This vulnerability can be exploited to exhaust the memory of a backend and OOM-kill it (when ovecommit is on), which results in a cluster-wide crash recovery. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions.
SeverityMedium
CVSS4.7
Exploit probability8. percentile0.2%
ProductPostgreSQL Anonymizer
PublishedOct 28, 2026
First seenNov 4, 2026
Weakness typeCWE-789CWE-789
How to fix
Update
- DALIBO PostgreSQL Anonymizer3.3.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| DALIBO PostgreSQL Anonymizer | 1 ≤ v < 3.3.0 | 3.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.