CVE-2026-105643

High

Description

Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new  security.embedPreviewUrl  configuration option at its default value. This issue is fixed in version 6.67.0.

SeverityHigh
CVSS7.3
Exploit probability—
ProductGhost
PublishedOct 5, 2026
First seenOct 5, 2026

How to fix

Update
  • ghost6.67.0 or later

Affected products

ProductAffected versionsFixed in
ghostnpm6.34.0 ≤ v < 6.67.06.67.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-105643 · Ghost · Dark Radar