CVE-2026-105818
Description
Vault's PKI secrets engine ACME server did not restrict certificate identities that ACME challenges do not validate when issuing certificates under the default directory policy. This may allow an ACME client to obtain a certificate containing unverified identity claims, potentially enabling impersonation toward systems that trust certificates issued by the affected Vault PKI mount. This vulnerability (CVE-2026-105818) is fixed in Vault Community Edition 2.1.2, and Vault Enterprise 2.1.2, 1.21.12, 1.20.17, and 1.19.23.
How to fix
- HashiCorp Vault2.1.2 or later
- HashiCorp Vault Enterprise2.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| HashiCorp Vault | 1.14.0 ≤ v < 2.1.2 | 2.1.2 |
| HashiCorp Vault Enterprise | 1.14.0 ≤ v < 2.1.2 | 2.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.