CVE-2026-10584
Medium
Description
Proxy server in Graph Explorer before 3.0.1 falls back to HTTP when certificate files are missing, which might allow remote threat actors to obtain sensitive information via interception of requests intended to be sent over HTTPS. To remediate this issue, users should upgrade to Graph Explorer v3.0.1 or later.
SeverityMedium
CVSS5.9
Exploit probability—
ProductGraph Explorer
PublishedJun 2, 2026
First seenJun 2, 2026
Weakness typeCWE-319CWE-319
How to fix
Update
- AWS Graph Explorer3.0.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| AWS Graph Explorer | 1.1.0 ≤ v < 3.0.1 | 3.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.