CVE-2026-105845
Description
Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.88.0 and canary versions before 4.0.0-canary.27, an untrusted user who can query readable collections through dynamic filters or joins can submit a request that causes SQL injection in the SQLite and Postgres adapters. This issue is fixed in versions 3.88.0 and 4.0.0-canary.27.
How to fix
- payload3.88.0, 4.0.0-canary.27 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| payloadnpm | 3.0.0 ≤ v < 3.88.0, 4.0.0-canary.0 ≤ v < 4.0.0-canary.27 | 3.88.0, 4.0.0-canary.27 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.