CVE-2026-10585
Description
A stored cross-site scripting vulnerability was identified in GitHub Enterprise Server that allowed an authenticated attacker to execute arbitrary JavaScript in another user's browser by injecting a crafted payload into the title of a Discussion in the Q&A category. The AnsweredQuestionStructuredDataComponent did not escape user-controlled Discussion titles before embedding them in a <script type="application/ld+json"> block, allowing the title to break out of the script context. The injection was escalated to a full cross-site scripting attack on GitHub Enterprise Server by leveraging JSONP callback support in the REST API to bypass the Content Security Policy. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.16.20, 3.17.17, 3.18.11, 3.19.8, 3.20.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.16.20, 3.17.0 ≤ v < 3.17.17, 3.18.0 ≤ v < 3.18.11, 3.19.0 ≤ v < 3.19.8, 3.20.0 ≤ v < 3.20.4 | 3.16.20, 3.17.17, 3.18.11, 3.19.8, 3.20.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.