CVE-2026-105855
High
Description
Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, the server fails to enforce a field-level access.update restriction on the password field of an authentication collection. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
SeverityHigh
CVSS7.1
Exploit probability—
ProductPayload
PublishedOct 6, 2026
First seenOct 6, 2026
Weakness typeCWE-284Improper access control
How to fix
Update
- payloadcms payload3.90.0 or later
- payload3.90.0, 4.0.0-canary.34 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| payloadcms payload | v < 3.90.0, 4.0.0 | 3.90.0 |
| payloadnpm | v < 3.90.0, 4.0.0-canary.0 ≤ v < 4.0.0-canary.34 | 3.90.0, 4.0.0-canary.34 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.