CVE-2026-106459
Description
Backstage is an open framework for building developer portals. From 0.3.0 until 0.3.8, the @backstage/plugin-scaffolder-backend-module-sentry package is affected by improper input validation in sentry scaffolder actions. An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. This issue is fixed in version 0.3.8.
How to fix
- linuxfoundation backstage1.54.8 or later
- linuxfoundation backstage\/plugin-scaffolder-backend-module-sentry0.3.8 or later
- @backstage/plugin-scaffolder-backend-module-sentry0.3.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| linuxfoundation backstage | 1.47.0 ≤ v < 1.54.8 | 1.54.8 |
| linuxfoundation backstage\/plugin-scaffolder-backend-module-sentry | 0.3.0 ≤ v < 0.3.8 | 0.3.8 |
| @backstage/plugin-scaffolder-backend-module-sentrynpm | 0.3.0 ≤ v < 0.3.8 | 0.3.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.