CVE-2026-106498
Description
Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.
How to fix
- linuxfoundation backstage_plugin-catalog-backend3.5.1, 3.6.2, 3.7.2, 3.8.2, 3.9.1 or later
- linuxfoundation backstage1.49.6, 1.50.5, 1.51.3, 1.53.2, 1.54.6 or later
- @backstage/plugin-catalog-backend3.9.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| linuxfoundation backstage_plugin-catalog-backend | v < 3.5.1, 3.6.0 ≤ v < 3.6.2, 3.7.0 ≤ v < 3.7.2, 3.8.0 ≤ v < 3.8.2, 3.9.0 ≤ v < 3.9.1 | 3.5.1, 3.6.2, 3.7.2, 3.8.2, 3.9.1 |
| linuxfoundation backstage | v < 1.49.6, 1.50.0 ≤ v < 1.50.5, 1.51.0 ≤ v < 1.51.3, 1.52.0 ≤ v < 1.53.2, 1.54.0 ≤ v < 1.54.6 | 1.49.6, 1.50.5, 1.51.3, 1.53.2, 1.54.6 |
| @backstage/plugin-catalog-backendnpm | v < 3.9.1 | 3.9.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.