CVE-2026-108500
Description
Input validation vulnerability in Apache ActiveMQ configured to use the LDAPAuthorizationMapPlugin allows an authenticated attacker to create or address a destination with a crafted name containing LDAP DN special characters (such as comma, plus, equals, backslash) can manipulate the LDAP search base used for ACL lookups. This issue affects Apache ActiveMQ: from 6.3.0 before 6.3.3, from 5.19.0 before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
How to fix
- Apache ActiveMQ6.3.3, 5.19.12 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache ActiveMQ | 6.3.0 ≤ v, 5.19.0 ≤ v | 6.3.3, 5.19.12 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.