CVE-2026-108709
Critical
Description
Authentication bypass within in-house network in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4.0.4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.
SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Kylin
PublishedOct 16, 2026
First seenOct 16, 2026
Weakness typeCWE-287Improper authentication
How to fix
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Kylin | 4.0.4 ≤ v ≤ 5.0.4 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.