CVE-2026-108837

High

Description

Allocation of resources without limits or throttling vulnerability in Apache Kylin. Given an attacker has got project admin permission, an cache API maybe used to cause computed-column resource exhaustion. This issue affects Apache Kylin: from 4.0.0 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Kylin
PublishedOct 19, 2026
First seenOct 19, 2026

How to fix

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Kylin4.0.0 ≤ v ≤ 5.0.4—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.