CVE-2026-110812
Description
Deserialization of untrusted data in the Gremlin graph data import component in Amazon Neptune engine might allow an authenticated remote actor with standard database permissions to execute arbitrary code and access internal service credentials. To remediate this issue, users not enrolled in auto-update should upgrade to Amazon Neptune engine version 1.5.0.0.(Backports to 1.4.8.1 and 1.4.7.1)
How to fix
- AWS Amazon Neptune Engine1.5.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| AWS Amazon Neptune Engine | 1.2.0.0 ≤ v < 1.5.0.0 | 1.5.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.