CVE-2026-1115

Critical

Description

A Stored Cross-Site Scripting (XSS) vulnerability was identified in the social feature of parisneo/lollms, affecting the latest version prior to 2.2.0. The vulnerability exists in the `create_post` function within `backend/routers/social/__init__.py`, where user-provided content is directly assigned to the `DBPost` model without sanitization. This allows attackers to inject and store malicious JavaScript, which is executed in the browsers of users viewing the Home Feed, including administrators. This can lead to account takeover, session hijacking, and wormable attacks. The issue is resolved in version 2.2.0.

SeverityCritical
CVSS9.6
Exploit probability—
ProductLollms
PublishedApr 10, 2026
First seenApr 10, 2026

How to fix

Update
  • lollms2.2.0 or later

Affected products

ProductAffected versionsFixed in
lollms lollmsv ≤ 2.1.0—
lollmsPyPIv < 2.2.02.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.