CVE-2026-111804
High
Description
Apache Traffic Server's experimental wasm plugin has a use-after-free in its transaction-close handler and forwards unvalidated guest-supplied metric IDs to the internal stats API. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.4, 10.2.0. Users are recommended to upgrade to version 10.1.5 or 10.2.1, which fix the issue.
SeverityHigh
CVSS8.2
Exploit probability—
Product
Apache Traffic Server
PublishedOct 21, 2026
First seenOct 21, 2026
Weakness typeCWE-416Use after free
How to fix
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Traffic Server | 10.0.0 ≤ v ≤ 10.1.4, 10.2.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.