CVE-2026-111811

Critical

Description

Apache Traffic Server's experimental tsmemcache plugin allows unauthenticated network read, write, and deletion of the shared proxy cache. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.15, from 10.0.0 through 10.1.4, 10.2.0. Users are recommended to upgrade to version 9.2.16, 10.1.5, or 10.2.1, which fix the issue.

SeverityCritical
CVSS9.0
Exploit probability—
ProductApache Traffic Server
PublishedOct 21, 2026
First seenOct 21, 2026

How to fix

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Traffic Server8.0.0 ≤ v ≤ 8.1.11, 9.0.0 ≤ v ≤ 9.2.15, 10.0.0 ≤ v ≤ 10.1.4, 10.2.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.