CVE-2026-112900

Critical

Description

Pillow is a Python imaging library. From 2.6.0 until 13.0.0, Pillow is vulnerable to argument injection when invoking Ghostscript for EPS input. EpsImagePlugin.Ghostscript passes a caller-controlled input filename after -f without converting it to a safe absolute path, so a name beginning with a hyphen can be interpreted as a Ghostscript option. An attacker who controls the filename can inject Ghostscript arguments. Arbitrary command execution specifically requires a leading @ argument-file filename and control of the referenced text file containing additional Ghostscript arguments; the reported chain reproduces with the default -dSAFER invocation. This issue is fixed in version 13.0.0.

SeverityCritical
CVSS9.8
Exploit probability—
ProductPython Pillow
PublishedOct 19, 2026
First seenOct 19, 2026

How to fix

Update
  • python pillow13.0.0 or later
  • pillow13.0.0 or later

Affected products

ProductAffected versionsFixed in
python pillow2.6.0 ≤ v < 13.0.013.0.0
pillowPyPI2.6.0 ≤ v < 13.0.013.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.