CVE-2026-11400

High

Description

An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through an affected wrapper. To remediate this issue, users should upgrade to AWS Advanced JDBC Wrapper version 4.0.1.

SeverityHigh
CVSS8.0
Exploit probability—
ProductSoftware.amazon.jdbc:aws-advanced-jdbc-wrapper
PublishedJun 5, 2026
First seenJun 5, 2026
Weakness typeCWE-426CWE-426

How to fix

Update
  • software.amazon.jdbc:aws-advanced-jdbc-wrapper4.0.1 or later

Affected products

ProductAffected versionsFixed in
software.amazon.jdbc:aws-advanced-jdbc-wrapperMaven3.0.0 ≤ v < 4.0.14.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.