CVE-2026-11440
Description
A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.
How to fix
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| theonedev onedev | 15.0.0, 15.0.1, 15.0.2, 15.0.3, 15.0.4, 15.0.5 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.