CVE-2026-11500

Medium

Description

A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.

SeverityMedium
CVSS5.0
Exploit probability—
ProductGithub.com/weaviate/weaviate
PublishedJun 8, 2026
First seenJun 8, 2026

How to fix

Affected products

ProductAffected versionsFixed in
github.com/weaviate/weaviateGov < 1.38.0-rc.01.38.0-rc.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.