CVE-2026-115417
High
Description
Memory allocation with excessive size value in the MQTT 3.1.1 compatibility adapter in AWS aws-c-mqtt before 0.16.2 might allow a remote actor to cause a denial of service of the client application. To remediate this issue, users should upgrade to aws-c-mqtt 0.16.2 or later, or to an AWS Common Runtime or AWS IoT Device SDK release that bundles it.
SeverityHigh
CVSS7.5
Exploit probability—
ProductAws-c-mqtt
PublishedOct 22, 2026
First seenOct 22, 2026
Weakness typeCWE-789CWE-789
How to fix
Update
- AWS aws-c-mqtt0.16.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| AWS aws-c-mqtt | 0.9.1 ≤ v < 0.16.2 | 0.16.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.