CVE-2026-115917

Low

Description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.

SeverityLow
CVSS3.4
Exploit probability—
ProductVllm
PublishedOct 26, 2026
First seenOct 26, 2026
Weakness typeCWE-942CWE-942

How to fix

Update
  • vllm vllm0.32.0 or later
  • vllm0.32.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllmv < 0.32.00.32.0
vllmPyPIv < 0.32.00.32.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.