CVE-2026-115918

Medium

Description

vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedOct 26, 2026
First seenOct 26, 2026

How to fix

Update
  • vllm vllm0.32.0 or later
  • vllm0.32.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.16.0 ≤ v < 0.32.00.32.0
vllmPyPI0.16.0 ≤ v < 0.32.00.32.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-115918 · Vllm · Dark Radar