CVE-2026-116675

High

Description

TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.

SeverityHigh
CVSS8.5
Exploit probability—
ProductTinymce
PublishedOct 27, 2026
First seenOct 27, 2026

How to fix

Update
  • tinymce8.9.3, 7.9.4 or later
  • TinyMCE8.9.3, 7.9.4 or later
  • tinymce/tinymce8.9.3, 7.9.4 or later

Affected products

ProductAffected versionsFixed in
tinymcenpm8.5.1 ≤ v < 8.9.3, 7.9.3 ≤ v < 7.9.48.9.3, 7.9.4
TinyMCENuGet8.5.1 ≤ v < 8.9.3, 7.9.3 ≤ v < 7.9.48.9.3, 7.9.4
tinymce/tinymcePackagist8.5.1 ≤ v < 8.9.3, 7.9.3 ≤ v < 7.9.48.9.3, 7.9.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.