CVE-2026-116687
Description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.
How to fix
- ckeditor547.7.4, 48.5.1 or later
- @ckeditor/ckeditor5-engine47.7.4, 48.5.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ckeditor5npm | 29.0.0 ≤ v < 47.7.4, 48.0.0 ≤ v < 48.5.1 | 47.7.4, 48.5.1 |
| @ckeditor/ckeditor5-enginenpm | 29.0.0 ≤ v < 47.7.4, 48.0.0 ≤ v < 48.5.1 | 47.7.4, 48.5.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.