CVE-2026-118254
Description
Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid writes pagination language strings into the DOM as markup instead of text. An attacker who controls the Grid language configuration can provide elements with event handlers, which execute in the hosting page origin when pagination controls render. Exploitation requires pagination to be enabled but does not require additional user interaction. This issue is fixed in 3.2.0.
How to fix
- @highcharts/grid-lite3.2.0 or later
- @highcharts/grid-pro3.2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @highcharts/grid-litenpm | 2.0.0 ≤ v ≤ 3.1.0 | 3.2.0 |
| @highcharts/grid-pronpm | 2.0.0 ≤ v ≤ 3.1.0 | 3.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.