CVE-2026-118256

Low

Description

Vue I18n is the internationalization plugin for Vue.js. From 9.0.0-beta.5 until 11.4.14 and 12.0.0-alpha.5, enabling escapeParameter, called escapeParameterHtml in the Legacy API, does not escape named interpolation values when the same translation call supplies both list and named values because escapeParams() processes only the list branch. Applications that render translations as HTML and pass untrusted named values with a list can insert attacker-controlled markup, including phishing links, forms, and layout changes, and can permit script execution when combined with the srcdoc sanitizer bypass or on releases without the sanitizer. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.

SeverityLow
CVSS2.1
Exploit probability—
ProductVue-i18n
PublishedOct 28, 2026
First seenNov 4, 2026

How to fix

Update
  • vue-i18n11.4.14, 12.0.0-alpha.5 or later
  • @intlify/core11.4.14, 12.0.0-alpha.5 or later
  • @intlify/core-base11.4.14, 12.0.0-alpha.5 or later
  • petite-vue-i18n11.4.14, 12.0.0-alpha.5 or later
  • @intlify/vue-i18n-core11.4.14, 12.0.0-alpha.5 or later

Affected products

ProductAffected versionsFixed in
vue-i18nnpm9.0.0-beta.5 ≤ v < 11.4.14, 12.0.0-alpha.1 ≤ v < 12.0.0-alpha.511.4.14, 12.0.0-alpha.5
@intlify/corenpm9.0.0-beta.10 ≤ v < 11.4.14, 12.0.0-alpha.1 ≤ v < 12.0.0-alpha.511.4.14, 12.0.0-alpha.5
@intlify/core-basenpm9.0.0-beta.12 ≤ v < 11.4.14, 12.0.0-alpha.1 ≤ v < 12.0.0-alpha.511.4.14, 12.0.0-alpha.5
petite-vue-i18nnpm9.2.0-alpha.7 ≤ v < 11.4.14, 12.0.0-alpha.1 ≤ v < 12.0.0-alpha.511.4.14, 12.0.0-alpha.5
@intlify/vue-i18n-corenpm9.2.0-alpha.7 ≤ v < 11.4.14, 12.0.0-alpha.1 ≤ v < 12.0.0-alpha.511.4.14, 12.0.0-alpha.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.