CVE-2026-11945

Medium

Description

PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a JSON document and placing malicious code inside a particular key-value pair. If a superuser calls the import_database_rules() or import_roles_rules() functions, the malicious code is executed with superuser privileges. The problem is resolved in PostgreSQL Anonymizer 3.1.1 and further versions

SeverityMedium
CVSS6.4
Exploit probability—
ProductDalibo Postgresql Anonymizer
PublishedJun 11, 2026
First seenJun 11, 2026
Weakness typeCWE-89SQL injection

How to fix

Update
  • dalibo postgresql_anonymizer3.1.1 or later

Affected products

ProductAffected versionsFixed in
dalibo postgresql_anonymizerv < 3.1.13.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.