CVE-2026-12241

Medium

Description

The Advanced Woo Labels – Product Labels & Badges for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improperly secure capability check on the 'save_meta_boxes' function in all versions up to, and including, 2.51. This makes it possible for authenticated attackers, with Contributor-level access and above, to create AWS labels that are rendered without proper escaping. The vulnerability was partially patched in version 2.46.

SeverityMedium
CVSS5.4
Exploit probability—
ProductAdvanced Woo Labels – Product Labels & Badges for WooCommerce
PublishedOct 1, 2026
First seenOct 1, 2026

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
mihail-barinov Advanced Woo Labels – Product Labels & Badges for WooCommercev ≤ 2.51—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.