CVE-2026-12957

High

Description

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

SeverityHigh
CVSS7.8
Exploit probability—
Product@aws/lsp-codewhisperer
PublishedJun 23, 2026
First seenJun 23, 2026
Weakness typeCWE-732CWE-732

How to fix

Update
  • @aws/lsp-codewhisperer0.0.113 or later

Affected products

ProductAffected versionsFixed in
@aws/lsp-codewhisperernpmv < 0.0.1130.0.113

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-12957 · @aws/lsp-codewhisperer · Dark Radar