CVE-2026-13769
Description
Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the umask has not been configured to restrict file permissions (the default on most systems) may allow other local users on the same host to read credentials written by certain CLI subcommands (aws codeartifact login, aws iam create-virtual-mfa-device, aws deploy register). To remediate this issue, users should upgrade to AWS CLI 1.44.78 (v1) or 2.34.29 (v2) or later.
How to fix
- amazon aws_command_line_interface1.44.78, 2.34.29 or later
- awscli1.44.78 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| amazon aws_command_line_interface | v < 1.44.78, 2.0.0 ≤ v < 2.34.29 | 1.44.78, 2.34.29 |
| awscliPyPI | v < 1.44.78 | 1.44.78 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.