CVE-2026-14181

High

Description

@fastify/middie versions 9.1.0 through 9.3.2 fail to guard the URL normalization step used by the standalone engine when incoming request paths contain malformed percent-encoded sequences. Inputs such as an incomplete percent escape or a truncated multibyte sequence cause the underlying decoder to throw synchronously, and the exception escapes the middie normalize step and terminates the Node.js process. The bypass affects applications that call middie.run directly on the standalone engine API, causing an immediate denial of service for all connected clients until restart. Applications using the Fastify plugin path are not affected because Fastifys error handler catches the exception. Patches: upgrade to @fastify/middie 9.3.3. Workarounds: migrate from the standalone engine API to the Fastify plugin path, where the framework error handler catches the exception.

SeverityHigh
CVSS7.5
Exploit probability—
ProductFastify\/middie
PublishedJul 1, 2026
First seenJul 1, 2026
Weakness typeCWE-248CWE-248

How to fix

Update
  • fastify fastify\/middie9.3.3 or later

Affected products

ProductAffected versionsFixed in
fastify fastify\/middie9.1.0 ≤ v < 9.3.39.3.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.