CVE-2026-14257

High

Description

brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.

SeverityHigh
CVSS7.5
Exploit probability—
ProductJuliangruber Brace-expansion
PublishedJul 23, 2026
First seenJul 23, 2026

How to fix

Update
  • juliangruber brace-expansion1.1.17, 2.1.3, 3.0.3, 5.0.8 or later
  • brace-expansion5.0.8, 3.0.3, 2.1.3, 1.1.17 or later

Affected products

ProductAffected versionsFixed in
juliangruber brace-expansionv < 1.1.17, 2.0.0 ≤ v < 2.1.3, 3.0.0 ≤ v < 3.0.3, 4.0.0 ≤ v < 5.0.81.1.17, 2.1.3, 3.0.3, 5.0.8
brace-expansionnpm4.0.0 ≤ v < 5.0.8, 3.0.0 ≤ v < 3.0.3, 2.0.0 ≤ v < 2.1.3, v < 1.1.175.0.8, 3.0.3, 2.1.3, 1.1.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.