CVE-2026-15007
Description
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repository release notes configuration file containing deeply nested YAML. When release notes were generated, the configuration file was parsed without a nesting depth limit, causing excessive resource consumption that could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.18, 3.18.12, 3.19.9, 3.20.5, and 3.21.3. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- docs.github.com/en/[email protected]/admin/release-notes#3.17.18
- docs.github.com/en/[email protected]/admin/release-notes#3.18.12
- docs.github.com/en/[email protected]/admin/release-notes#3.19.9
- docs.github.com/en/[email protected]/admin/release-notes#3.20.5
- docs.github.com/en/[email protected]/admin/release-notes#3.21.3
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| GitHub Enterprise Server | 3.17.0 ≤ v ≤ 3.17.17, 3.18.0 ≤ v ≤ 3.18.11, 3.19.0 ≤ v ≤ 3.19.8, 3.20.0 ≤ v ≤ 3.20.4, 3.21.0 ≤ v ≤ 3.21.2 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.