CVE-2026-15738

High

Description

Incorrect behavior order in the Gateway API listener-rule generation in Amazon AWS Load Balancer Controller before 3.4.2 might allow an authenticated remote user to intercept, spoof, or deny another namespace's gRPC traffic on a shared Gateway via a crafted HTTPRoute resource. To mitigate this issue, users should upgrade to version 3.4.2.

SeverityHigh
CVSS8.5
Exploit probability—
ProductAmazon Aws-load-balancer-controller
PublishedJul 14, 2026
First seenJul 14, 2026
Weakness typeCWE-653CWE-653

How to fix

Affected products

ProductAffected versionsFixed in
Amazon aws-load-balancer-controllerv < 3.4.23.4.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.