CVE-2026-15895

High

Description

OS command injection in the npm package loading component in AWS jsii-diff before 1.131.0 might allow context-dependent attackers to execute arbitrary commands via crafted package specifiers passed to the npm: source argument. To mitigate this issue, users should upgrade to jsii-diff v1.131.0 or later.

SeverityHigh
CVSS7.8
Exploit probability—
ProductJsii-diff
PublishedJul 15, 2026
First seenJul 15, 2026

How to fix

Affected products

ProductAffected versionsFixed in
jsii-diffnpmv < 1.131.01.131.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.