CVE-2026-15996
Description
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to cause excessive CPU consumption and exhaust the pool of request-handling worker processes by sending a crafted form-encoded HTTP POST request containing deeply nested parameters. Because request parameters were parsed before routing and authentication, any POST endpoint could be used to trigger the condition, which could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.3, 3.19.7, 3.18.10, and 3.17.16.
How to fix
- github enterprise_server3.17.16, 3.18.10, 3.19.7, 3.20.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.17.16, 3.18.0 ≤ v < 3.18.10, 3.19.0 ≤ v < 3.19.7, 3.20.0 ≤ v < 3.20.3 | 3.17.16, 3.18.10, 3.19.7, 3.20.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.